Commit 04e9ac02 authored by gerd's avatar gerd

Updates for findlib-0.4


git-svn-id: https://godirepo.camlcity.org/svn/lib-xstrp4/trunk@7 56444827-45db-0310-81c6-95464f7ca4c4
parent 68d1cfea
version = "0.1.1"
requires = ""
archive(camlp4) = "xstrp4.cma"
version = "1.0"
requires = "camlp4"
# This line counts when the compiler is invoked with
# ocamlfind ocamlc -syntax -package xstrp4
archive(syntax,preprocessor) = "xstrp4.cma"
# This line counts when a toploop is running and
# someone types #require "xstrp4".
archive(syntax,toploop) = "xstrp4.cma"
......@@ -20,9 +20,9 @@ $(ARCHIVE): $(OBJECTS)
$(OCAMLC) -a -o $(ARCHIVE) $(OBJECTS)
sample: sample.ml xstrp4.cma sample.file
ocamlc \
-pp 'camlp4 $(ROPTIONS) pa_o.cmo ./xstrp4.cma pr_dump.cmo' \
sample: sample.ml
ocamlfind ocamlc \
-package xstrp4 -syntax camlp4o \
sample.ml \
-o sample
......
......@@ -3,7 +3,7 @@ does. See sample.ml for examples.
You need camlp4 to build the extension.
You need findlib to 'make install'.
You need findlib to 'make install'; AT LEAST VERSION 0.4 OF FINDLIB!
BUILD:
......@@ -19,8 +19,15 @@ the compiled files to their standard places. The package name is then
If you do not have "findlib", just copy the files manually where you like
them.
HOW TO USE IT:
See sample.ml for explanations. See the Makefile how to compile sample.ml.
CHANGES:
Changed in version 1.0:
Support for findlib-0.4
Changed in version 0.1.1:
Updated the URLs in documentation.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment